Issue with Inbound Calls to Talkdesk Contact Center

Incident Report for Tufts University

Resolved

The issue with inbound calls to Talkdesk Contact Center is resolved at this time. TTS is continuing to monitor the situation.
Posted Jul 02, 2026 - 12:37 EDT

Investigating

There is currently an issue with inbound calls to Talkdesk (our cloud contact center) - we have escalated with our vendor as an urgent matter, and will post additional info here as available. This is not isolated to Tufts, it is part of a larger issue.
Posted Jul 02, 2026 - 12:24 EDT
This incident affected: Communication & Collaboration.