Building Access issues in Medford residence halls
Incident Report for Tufts University
Resolved
The Medford residence hall building access issues have been resolved. If you continue to have difficulty using your Tufts ID card accessing your Medford residence hall, please email accessreq@tufts.edu.
Posted Sep 11, 2024 - 17:09 EDT
Update
TTS continues to investigate the issue affecting access to Residence Halls in Medford. Next update: 3:00
Posted Sep 11, 2024 - 13:50 EDT
Investigating
Tufts Technology Services has been made aware of building access issues in Medford residence halls. Next update: 1:30 pm.
Posted Sep 11, 2024 - 12:25 EDT
This incident affected: Other.